Troubleshooting Guide

PROBLEMPOSSIBLE CAUSECORRECTION
Humming Noise (intermittent)Ripple ControlCall your electricity provider to determine if you have ripple control in your area.
Your provider will supply you with a ripple control filter free of charge.
Ticking Noise1. Blade & Mounting bracket screws loose
2. Canopy screws loose
3. Mounting bracket not securely anchored to a solid joist or beam.
1. Tighten blade and mounting bracket screws.
2. Tighten canopy screws.
3. Tighten bracket mounting screws.
Fan WobblesUnbalanced bladesUse supplied balancing kit to balance out each blade. Take time to BALANCE the fan.
This procedure removes up to 99% of unwanted noises originating from the top canopy and hanging ball.
Fan RattlesLoose bottom plateTighten bottom plate on fan
Fan not operating using wall controlQuick connect plugs not connected properlyDisconnect and reconnect plugs ensuring they are making good contact.
Fan not operating using remote1. Battery may be dead
2. Dip switches on remote and receiver do not match
3. Quick connect plugs not connected properly between mounting bracket and receiver or between receiver and fan.
1. Replace with new battery
2. Check dip switches are set to th same setting on both remote and receiver
3. Disconnect and reconnect plugs ensuring they are making good contact.
Indicator on DC remote is not illuminatingCheck the batteryBattery may be installed backwards or may need replacing.
DC Fan not operating with remoteRemote is not properly paired with fanFollow pairing procedure in the instruction manual.
For Aviator, Concorde II, Hercules – While holding the set button on the back of the remote, switch power on to the
fan via wall switch and continue to hold the set button for at least 5 seconds.
For Concorde, Galaxy II, Tempest DC, Tempo DC – While holding the Fan On/Off button on the remote, switch power on
to the fan via wall switch and continue to hold the Fan On/Off button for at least 5 seconds.
Fan does not rotate after pairing and/or receiver continually beepsQuick connect plugs not connected properly between mounting bracket and receiver or between receiver and fan.Disconnect and reconnect plugs ensuring they are making good contact.
Perform pairing procedure again.